Cannot install **any** packages


#1

Hi,

I installed Atom on Windows 8.1 (64bit) using Chocolatey, and made sure it is the most up-to-date version. I tried installing a few packages using APM in Git Bash (which does not recognize APM as a command). Thankfully it was recognized on command prompt, so I used that, and got a gyp error. Which is unsettling, since I am a Node.js developer and already have Visual Studio, Git, Python 2.7 etc. installed. So I tried using the settings menu inside Atom itself to install packages, and I’m still getting the gyp error. So I re-installed everything, Atom, Chocolatey, Git, Visual Studio, Node, Python, even Github for Windows, and tried the whole process again and I’m still getting the errors. I am running in Administrator mode. The gyp errors themselves are not helpful (this is the entirety of the error trace):

gyp error

What can I do from here, to ensure everything works as it should? Is there a way to see a more helpful error trace?


Installing packages fails on compiler tools
#2

Is it possible you’re behind a firewall that disallows https calls?
I have that in public hotspots sometimes.
Can you reach any of the url’s shown if you type them into a browser or something?

Edit: Although http status 200 should be fine, I guess.
There must be more output before this extract, can you show us the whole thing?


#3

No proxies or firewalls. This is my home internet connection. And I promise you, that is the whole output - I enter apm install xyz and i get that.


#4

@kevinsawicki Any ideas?


#5

win8 64 but node detects win32?
maybe python27 is installed as 32bit version?


#6

This is exactly why I’m confused, everything I’ve installed that had the option of either 32 or 64 bit, I always went with the 64 bit. I’ve used node-gyp successfully on numerous occasions for the last year and a half, for more projects than I can even count on my fingers, but these packages just refuse to work :confused:


#7

Mind opening up a new issue on the apm repo with the output you are seeing as well as the output of apm -v.

I’m not sure what is going on, can you try deleting your C:\Users\<you>\.atom\.node-gyp and C:\Users\<you>\.atom\.npm and running again?


#8

Had this problem on Linux plattform after some build issues, but after deleting the .atom dir in my $HOME I got it to work. Not sure about the windows plattform. Is the settings in appdata?


#9

I experienced the same issue. I have already submitted an issue here: https://github.com/atom/apm/issues/167

I will try rogernordqvists workaround and see if it works.