Cannot get python to run from Atom on Windows


#1

I am using Atom to help learn Python. I have looked on the site and they said that to auto run the code you just press shift+control+b. However, that does nothing. I have launched it from command line, but that does not make a difference either. What am I missing?


#2

Can you mention what you mean by “the site” here? That would help people understand which package you need help with.


#3

Oh. Maybe I need to install the package “script”!


#4

Weird, when I downloaded it and extracted it into the .atom/packages folder I get this when I start it up.


#5

Don’t do that manually. The proper way to install a package is using the Settings View or apm install package-name from the command line.

You should delete the directory you created in ~/.atom/packages and then use one of the above methods to install the package.


#6

Figured that out and got it installed now. However it keeps telling me that ‘python’ is not a recognized as an internal or external command. Basically I cant run a ‘python’ command from CMD. Not sure why though, since I installed it.


#7

For that one, I’m not the best person :confused: Perhaps someone else can help out?


#8

I got it figured out. Sorry for all the bother. I had to point the script package to my C:\Python34 directory. Now it works like a charm.


#9

It’s no bother at all. I’m glad it got figured out :grinning:


#10

Hi, facing exactly the same problem. Could you plz tell me how you pointed the script package to the Python directory?
Best.


#11

Hi,

First of all make sure you have added Python to the path environment variable.

  1. Right mouse button click on Computer -> Properties -> Advanced system settings.
  2. On the Advanced tab select Environment Variables.
  3. System variables -> Path -> Edit.
  4. type ;
    Note: Only type semicolon
  5. Copy paste the path to where python is installed after the semicolon.
  6. Click OK until all windows are closed.

Then add the script package through Atom (File -> Settings -> Packages).

Now go to the folder in which your tests are located then Right mouse button click and select “Open with Atom”.

That’s it to run scripts press Ctrl + Shift + b.


#12

thanks !!! i have been having so much trouble and now it finally works!!! thanks :heart_eyes:


#13

i am not a computer person . i just do some python programming in my gcse computing lessons , i am
having the same error but do not now anything about path enviroment variable ect.
i have just downloaded atom and the script package . i am trying to run python and it is not working
please help
thanks in advance


#14

What operating system are you using?


#15

Windows 10


#16

Hi I have been using Brackets for most of my coding with Visual Studio Code, lately started working on Atom and started learning python and I have edited environmental variables for my pc and set a path there and downloaded script in atom but still the same error ie. python is not recognized as internal or external command error is popping up again. Any help of suggestion of where I am going wrong.
Thank Ypi.


#17

What happens when you try to execute python from the command line?


#18

Its working fine now, I did not get the correct path since it installed somewhere deep in my C drive. Had to Uninstall and install again. To be sure for general purpose, while installing python make sure you change the location of where its going to be installed. It helps in future.
Thanks for responding anyway :slight_smile:


#19

So I did what you did, but it still says this
“‘python’ is not recognized as an internal or external command,
operable program or batch file.
[Finished in 0.034s]”
and from there I have been trying to troubleshoot it for lots of places.
Pls help


#20

Does Python work in the normal command prompt?