Cannot find module 'atom-package-dependencies'


#1

—when I tried to install atom-ternjs-0.5.6 on my own.


#2

If you are attempting to install the package manually, this can happen because the npm dependencies have not been installed. For this reason you should always use the settings view or apm install to install packages, which will install all the necessary dependencies.

To fix this for now, you can run apm install in the package directory.


#3

Thanks. But which directory?


#4

Wherever you installed the package - it should be ~/.atom/packages/atom-ternjs. On Windows it would be C:\Users\your-user\.atom\packages\atom-ternjs. However, you probably should just remove it and install by running apm install atom-ternjs.