Cannot delete files in atom, in Linux


#1

Hi!
As the title says I cannot delete files or folders. I don’t get any errors on DevTools or command line if I run atom with the -f flag. I can delete the files from command line with no problems, the permissions

I get the same behaviour if i use the --safe flag.

any clue?

cheers!


#2

Sorry i send the post before i had finished:
I was saying that the permissions allow me to delete from comand line with no problem.


#3

You probably don’t have gvfs-trash installed. It’s a program that implements the FreeDesktop trash specification, and is used by atom-shell to trash files. In debian (and derivatives) it’s installed with the gvfs-bin package. For other distros I don’t know which package it is in, but I’m sure you now how to use google :slight_smile:


#4

Hi! Thanks for your answer, you gave me the path to follow and solve it. I had gvfs-trash installed, the problem was that the partition where the files that I was trying to delete were located didn’t have a .Trash-{my_uid} folder in the root directory. I created it, changed uid owner and now it works perfectly.

Cheers!!


#5

Good to hear you could fix it! :smile:


#6

I can confirm that creating this folder fixes the issue in Atom.
But now the files and folders deleted in atom don’t end up in the Trash Can.
I have to manually navigate to /.Trash-{my_uid}/files and then delete them from their periodically.
Anyone got any ideas for a fix?


#7

Hi brad. Maybe you could add a daily cron task for that.