Can you use wildcards in customFileTypes


I’d like to do this:

  'source.dockerfile': [

But it doesn’t seem to recognize the wildcard at the end


I wanted to test RegExp in order to answer your post, but then I noticed that all the files starting with Dockerfile were already recognized as Docker files. Can you maybe give more specific example for a name you’d like to use?


we have several files named Dockerfile-foo or Dockerfile-bar. using the snippet above, they are not recognized. It seems as if the wildcard isn’t recognized


From the language-docker README:

Highlighting based on wildcards is not supported in Atom. You can use package file-types with this in you config.cson to enable it.

 "file-types": {
   "^Dockerfile\\..*$": "source.dockerfile"