Can someone help me figure out why Atom is so slow to open for me?


#1

I will include a Timecop screenshot even though Atom seems a lot slower that Timecop would seem to suggest.
The editor has no open projects at the moment and I only have a few packages and no custom themes (but I do have a custom font).

I am happy to give more detailed information as required but I’m not sure what’s needed to solve the problem.

Timecop


#2

Is it possible you opened atom within a large project ? prehaps your home directory ?
If you look at timecop activation, first 3 are

  • get icons of project files
  • get git status of project files
  • try to sort the project filename !

Is it possible you have a .git folder in your home directory ?


#3

Yes, I have a GitHub folder if that is what you mean.

But all my Github projects are closed in Atom.


#4

Does the slowdown happen if you start Atom from the command line with atom --safe?

The question was if you have a folder named .git in your home directory.


#5

Its even slower as safe mode opens a empty file called ~~safe and the contents of my personal user folder.
I only have a .gitconfig and a GitHub folder not a .git folder


#6

It sounds like you typed atom ~~safe instead of atom --safe. If not, then that’s a really weird bug.


#7

Hello.

For analysis by others, please try the following:

  1. Open Atom normally.

  2. Clear out all project folders; tree-view should be empty.

  3. Open safe mode from the command line.
    Ensure to use -- [minus minus] and not ~~ [tilde tilde].
    (@DamnedScholar: I tested, ~~ does what he described.)

  4. The result should open as shown.
    Note the green icon at left bottom.
    (Please ignore the specifics of the command line commands I used)
    Show how SAFE mode looks like

What are your results?
(A picture would be welcome - thank you.)

Good luck.


#8

I did type atom ~~safe instead of atom --safe.


#9

So what happens when you use the correct switch and open Atom in safe mode?


#10

@DamnedScholar
@danPadric

I opened it using atom --safe
I got Atom in safe mode with the green icon in the corner and a single untitled empty file open that wasn’t open when i last closed it.
I think mine is set to open a new file when its opened with no open files.


#11

Good to have your feedback per picture - thank you.

Not much worried about that part to much (about the empty file).
You could change the behaviour if you wish to do so in the settings (Ctrl + ,).
How was the “experience”; was there any performance difference?


#12

It’s much faster both in safe mode and not in safe mode, but ONLY after I booted into safe mode earlier today.


#13

@DamnedScholar: Thank you for helping.

@benmanuel:

I understand you do get better results in SAFE mode.
I understand that SAFE mode is far better.

Sorry… I am not following –
when again using NORMAL mode: is the experience the same as original. Or different.

Note that if you have a difference between SAFE and NORMAL mode, it indicates that there is a package that is giving this issue. You could deactivate some packages and see what you can do to better the result for NORMAL mode. Not only community packages some of the core ones can give trouble too.

Spelling and anything to do with Git or Github are the first things I recommend.

This is as far as I can help today.
Hopefully others can follow through on feedback you give.

Cheers.


#14

@danPadric
@DamnedScholar

Thanks both of you.


#15

Strange. Well, no way to figure out what was wrong if we can’t make the slowness happen again, but at least it’s fixed.


#16

To me it seems like @benmanuel got their project folder set to their home directory. Once that was cleared as per @danPadric’s instructions the slowness went away. I doubt it had anything to do with safe mode.


#17

I concur with your assessment.