Can not publish. "Creating new version failed: Git tag not found"


#1

Tried looking all over google and this board, still cant figure it out.

I try publishing v 0.1.0 and get the error.

$ apm publish minor
Registering behavior-syntax done
Preparing and tagging a new version done
Pushing v0.1.0 tag done
Publishing behavior-syntax@v0.1.0 failed
Creating new version failed: Git tag not found
<

this is the package https://atom.io/packages/behavior-syntax

Tags are listed on github, I’m lost.

Thanks for taking the time!


#2

Have you run apm login?


#3

Yes sir I have.

edit* I just tried it again to push a patch and it worked, idk what happened. sorry to waste your time.


#4

Another question lee, is there anyway to get an old package removed? I accidentally unlinked the repo.


#5

What’s the name of the package? And do you want to republish it?


#6

Hey lee, sorry I just saw this.

The other package was called westworld-syntax, which is what I wanted to name this theme originally but I accidentally unlinked the repos. Ideally I’d like to use that name but at this point deleting it would be fine too. This is more a project for learning than anything anyway.


#7

It’s been deleted. You can republish using the same name if you want.