Can not install or search for packages - Connection Refused


#1

Anxious to try Atom. We do not have a proxy at the office but certain some restrictive firewalls. So, i can’t set any http-proxy or https-proxy settings as we do not have any proxies. I have set strict-ssl=false. I get a connection refused on any search or install request for a package. (econnrefused).

I am on apm 1.4.0, npm 2.13.3 node 0.10.40 and atom 1.2.4, on windows 7 enterprise.

I do not see any way around this issue other than attempt to download a package manually and install it, but that does not look to be a supported procedure, for example not downloading required components.

I’ve also seen the recommendations not to use npm to install atom packages.

Before I give up, is there a supported workaround I can use at the office? Thank you.


#2

Are you at the office now? If so, if your office doesn’t have any proxies, how are you posting here?

If the office firewall is too restrictive, then no, there is no workaround for that other than taking your machine someplace outside the firewall. And no, there is no supported method for manually installing a package. Besides, even if you got packages manually installed, you wouldn’t be able to update Atom or the packages.


#3

We do not have any proxies. This is a bummer, but I do understand what you are saying. I wish I knew what was being blocked, because if it’s a simple http get request, which from running verbose seems to indicate that, I am able to hit that url in a browser. If this is a new clue, and possibly a different issue, please offer any assistance to further troubleshoot.

The url that showed up was https://atom.io/api/packages. In verbose mode, the proxy shows as null, which I guess I would expect as we have no proxy.


#4

In coming to this webpage to post on the forum, your web browser makes a connection to https://discuss.atom.io on port 443. I assume you also have no problem connecting to non-https websites on port 80. If you can do this from the office, one of the following is most likely true:

  1. Your office has no firewall
  2. Your office has a firewall and has a standard proxy setup
  3. Your office has a firewall that whitelists or blacklists sites and https://discuss.atom.io is allowed

Since apm uses HTTP/S connections to download packages, this means that if you can get to this forum via a web browser then it is almost certain that there is some way to configure apm to install packages.

  • Given that you are getting the connection refused error, this typically means that there is a firewall of one kind or another … so that rules out option #1.
  • Given that you are getting the connection refused error for https://atom.io in apm but not for https://discuss.atom.io in your web browser, that would almost assuredly rule out option #3

This leaves us with option #2 being the most likely candidate. But you keep repeating:

we have no proxy

How do you know this?


#5

Ok, you’ve cornered me! I’m definitely a developer and not a network expert, as you can clearly see. We must have some proxy, transparent would be the word I would guess, but not currently sure how to detect it or get the value of the proxy. IPconfig /all of course reveals nothing.

Is it something I have to ask the corporate folks or can I determine it myself?

Thanks for your patience.


#6

It should be able to be determined from your machine. It’s been a few years since I’ve used Windows, so I’m not sure I can recall off the top of my head but I believe that you can follow these instructions … but rather than changing the proxy settings, just read them:

http://windows.microsoft.com/en-us/windows/change-internet-explorer-proxy-server-settings#1TC=windows-7

If that doesn’t work … there is this big long list of suggestions :laughing:


#7

Yeah, I previously looked at that. No proxy is configured there, however, there is a proxy configuration script. I would imagine the purpose of a proxy config script is to have the proxy server set dynamically. It’s crazy that it’s only configured in IE. I will respond back in about an hour or two. Thanks again!


#8

No luck. A tunnel could not be created. I think for now I’m going to have to give up or become stronger in network skills. Thanks for your help.


#9

Sorry I couldn’t help more :confused:


#10

when i do apm update
i get a 404 error when a package should be downloaded

EDIT: now i have only 1 (instead of 2) update and its working again