Can not install atom & amp commands - help request


#1

Hello, I have downloaded Atom to an iMac OS X 10.9.5
Ran which atom in Terminal - nothing returned
ran Window: Install Shell Commands - returned message box
with: Failed to remove /usr/local/bin/atom
Any help appreciated.


#2

Try sudo rm /usr/local/bin/atom, then reinstall the shell commands.


#3

Thanks DamnedScholar
Total novice here trying to find a way into web site development.
Found TextEdit too labour intensive and looked for something better.
Hence downloaded Atom from atom.io and followed next installation instruction to check/install shell commands but immediately have problem beyond my “level”.
Looks like I need to learn MacOS Terminal commands first.

response to sudo rm command was
rm: /usr/local/bin/atom: No such file or directory

At least I learned a bit about rm and sudo commands!
but why I need sudo is a puzzle since I am signed in
as an admin with the password it requests.

Retried Atom>Install Shell Commands anyway - slightly different result msg box:
Failed to install shell commands
Failed to remove ‘/usr/local/bin/apm’

I can not understand why the install shell commands
is trying to remove what it is supposed to install
and is fussed about failing that.

googled what & where is /usr/local/bin
Finder>Go shows /usr/local/bin contains one file: /atom type alias
in case files hidden, I tried Terminal sudo ls /usr/local/bin
and got same result: atom

so tried Terminal: which atom - which originally gave no response
and got confirmation response this time:
/usr/local/bin/atom

but when I try Terminal: which apm no response
so I assume I still need to install a shell command named amp


#4

It’s always good to be familiar with the basic operations of your computer, especially when you’re using a Unix-based machine. I don’t know if installing shell commands is important for MacOS if you don’t use the shell, though. I was also under the impression that Atom attempted to install them automatically.

but why I need sudo is a puzzle since I am signed in
as an admin with the password it requests.

For safety. You’re signed in as a user who has access to sudo. When you invoke sudo, the next command is run as the user root, which has unlimited permissions. There are a number of reasons for doing things this way, but the main one is just so that important files don’t get messed with unless it’s deliberate.

Try sudo rm /usr/local/bin/apm. It seems to have worked with atom.


#5

Thanks for all the extended advice.
particularly that I may not need the shell commands.
I will push on without apm and see how I go.

I did try that last rm … amp - had the same thought
but it did not work :frowning:


#6

a spell check changes apm to amp