Can not install any Atom packages - Windows 10


#1

After installing Atom (latest version from the Atom.io site) for Windows 10 64 bit, the install of all packages is failing.

After a lot of investigation, I believe that it is a problem with folder permissions that were set when Atom was installed or when the APM creates directories at installation time.

It seems that the c:\users<username>\AppData\Local\Temp folder has been given Read Only privileges that is causing the installation to fail. I forced deleted the TEMP directory and it was re-created with RO privileges at the next install.

Because of this, installation of packages from apm (command line) is failing with a message:

EPERM: operation not permitted , lstat 'C:\users<username>\AppData\Local\Temp… ’

with what appears to be a randomly generated directory under it.

  • I have forced deleted the Temp directory and tried to reinstall a number of times with the same error.

  • I have manually created an empty Temp directory and during the install process, all the directories that are created under it are created with Read Only privs.

  • This problem occurs when Atom is in both safe and regular mode.

  • I have Atom and the packages I need installed on Mac and Linux. They just will not install on Windows 10 (32 and 64 bit). I also can not confidently say that Atom did a clean install but I can get it up and running.

  • Yes – the user (me) is an administrator

Not sure where to go from here after about 5 hours of noodling around trying to figure out what is going on.

Help?? Ideas ??


#2

Replying to my own post…

The problem was an (overzealous) Virus Protection problem (Webroot). I disabled the Virus Protection and all is well. The package installed perfectly. I will most likely have to do this for every package. It seems that virus protection interferes with normal installation of packages but not with the editor itself.

Lesson learned – (this thread helped) – https://github.com/Medium/phantomjs/issues/19