Can i stop bracket-matcher from inserting double backticks from a language grammar?


#1

(i think bracket-matcher is responsible for this behavior. Could be wrong on that.)

i’m maintaining a powershell language grammar for Atom and backticks in powershell are an escape or line continuation character, and inserting a pair of backticks when typing a single backtick isn’t really needed, just one will do :wink: Here’s the relevant issue in GitHub if you’d like some more information.

i’m not sure if this is possible, but is there a way to override (or disable) bracket-matcher’s insertion of a pair of backticks? Ideally, it’d be great to be able to keep backticks from causing this behavior but still allow the other smart quote insertion to occur!


#2

Yes, bracket-matcher is responsible for this functionality. No, I don’t believe the list of pairs can be customized in this way. You might want to open a bug on the bracket-matcher package.


#3

@jugglingnutcase If you open a bug on bracket-matcher, link it here. Customizing that behavior inside a language would also be nice for LaTeX, which uses two backticks as an open quotation mark and two single quotes as a closing quotation mark.

For your issue, it’s probably easiest to be able to specify a particular match to turn off. For the one I mention, language package authors would need to be able to define language-specific pairs.


#4

Thanks @leedohm :smile:

@jtkiley thanks for the input. i’m glad to know i’m not the only one who thinks this would be a beneficial behavior.

i plan on opening an issue on bracket-matcher for this (i’ll link it here too), i think it would be useful across a bunch of packages.


#5

OK, i’ve created an issue on the bracket-matcher repository.