Call the hunspell failed with code of null


#1

linter-spell is not working for me. When I start Atom it shows me this error:

linter-spell: Dictionary request failed
Call the hunspell failed with code of null.

I have verified I have a hunspell installation in my Ubuntu 16.04 OS.

I have seen on this thread the answer is:
“I set the locale to en-GB and gave it the path of the hunspell directories (/usr/share/hunspell)”

But I have no idea where to set this locale and path. Where is this done?


#2

I’ve had that error before on OSX and had to set the full path tu hunspell in the options to get rid of the “code of null” error.


#3

I no longer get the error when Atom starts. To solve the error I opened the Settings tab using Ctrl+, (that is control, and comma keys simultaneously, not the control, plus sign, and comma keys) .

On the left side in Settings tab I selected Packages. In the filter on the right I entered “linter” and below this selected “linter-spell”.

I scrolled down to see the “Settings” field group and made my entry in the “Spell Path” field. Because I have a Firestorm Viewer installation hunspell was not in its usual path. The usual path “/usr/share/hunspell” which I found by using the command “dpkg -L hunspell-en-us” did not work. The path that does work to eliminate the error I found by using the command:
find "./" -name "*hunspell*"
What is now entered in the “Spell Path” field is:
/home/myusername/Downloads/FirestormViewer.org/Phoenix_FirestormOS-Releasex64_x86_64_5.0.7.52912/lib/

Although I no longer get that “hunspell failed” error, or any other errror, when Atom starts up, I still am not able to get hunspell working. When I test it by deliberately misspelling a word in my webpage’s text, and save the html page, the misspelling is not indicated by linter. The linter warnings, errors, and infos indicators at the bottom left of Atom’s window remain all zeros. Something still is wrong.