C++ in atom problem


#1

I just started C++ and I encountered this error

Unable to start Clangd language server
Tried to spawn process using executable /usr/bin/clangd, which does not exist. Ensure you have correctly configured the path to Clangd in the package settings.

also, I am pretty sure its tied to this issue as well


#2

Have you installed Clangd?


#3

I don’t think I have but I will check tomorrow


#4

I just installed the LLVM Clangd for Windows 64 bit and now its still asking me this


#5

Which packages do you already have installed?
In other words - which package gives you that message?

You can get a list of packages executing in the terminal: apm list --packages


#6

I got this

Community Packages (12) C:\Users\jaspe_6sgtnwl\.atom\packages

├── atom-discord@1.6.1
├── atom-ide-debugger-native-gdb@0.7.3
├── atom-ide-ui@0.13.0
├── autocomplete-gml@0.1.7
├── city-lights-icons@1.1.1
├── formatter@2.12.4
├── gcc-make-run@0.2.12
├── ide-cpp@0.0.3
├── ide-typescript@0.7.9
├── language-gml@0.5.0
├── minimap@4.29.9
└── teletype@0.13.3

#8

There’s something you neglected to mention: you’re running Windows. This is important because the error message presents a Linux-shaped path. Perhaps there is a configuration in the package you’re using that points to where Clangd is installed, and you need to change it to fit your computer.


#9

@danPadric was it Visual Studio Code

I will try to see what I can do


#10

I have tried to get C++ up and running for Atom on my Windows 10 machine. I have failed to do so - but is not as dedicated as you to get it functional.

My rest of my views are best voiced in private.