[C++] gcc could not be spawned


#1

I am new to atom and I’ve got this problem.

I set C:\MInGW\bin in my path environment variable and C:\MInGW\bin\g++.exe in linter-gcc as GCC executable path. When I’m compiling and running my .cpp file I’ve got message “'gcc ’ could not be spawned. Is it installed and on your path? If so please open an issue on the package spawning the process.” (it’s shown below). I tried multiple solutions but it still doesn’t work.

Could you please help me?


#2

Have you closed and reopened Atom since you changed the environment variable?


#3

Yeah, of course


#4

I don’t think that it’s necessarily obvious that closing the program can help it find what’s essentially a lookup table.


#5

Okay, I’ve solved it. I put c++ flag in a wrong place. Now everything works. Thanks


#6

how did you solve it?