Building From Source - Absurdly Simple Non-Issue With Scripts


#1

As the title suggests, I am trying to build atom from source on my Ubuntu machine. I’ve installed and configured all of the dependencies as described on github, and am now stuck on running the scripts in the repository.

First script: script/build
Me: Okay, no problem. I navigate down and find the proper script and run "sudo build"
Ubuntu: Command not found
Me: Alrighty, I must have to run it like I’d run a shell script. "sudo ./build"
Ubuntu: Command not found
Me: FFFFFFFF

Is there something I’m missing? This issue is laughably simple, but i just don’t know how to move forward here.


#2

The command you need to execute from the root of the Atom repository to build Atom from source is literally script/build. See the “Scripts to Rule Them All” GitHub Engineering blog post for information on the pattern.


#3

Thanks for the response, @leedohm
I’ve tried running “sudo script/build” and “sudo ./script/build” (just in case) from the scripts directory, the atom-master repository, and one directory above the repository, and Ubuntu consistently doesn’t recognize the command.

I don’t suppose there is anything else I might check?


#5

Just script/build should be all you need to run. You shouldn’t need sudo to build.


#6

@leedohm That worked just fine… I wonder why ‘sudo’ prevents it from working :confused:


#7

It’s actually sudo that doesn’t understand many commands. I don’t understand the logic behind it. For example, sudo cd doesn’t work.