Building done and testing failed


#1

Can you solve this error problem when test failed? How to fix and patch the problem?

See the error problem is given below

tester@ubuntu-MXC061:~/atom$ script/build
Node: v0.10.35
npm: v2.13.3
Installing build modules...
Installing apm...
Installing modules ✓
Deduping modules ✓
Running "download-electron" task


Running "download-electron-chromedriver" task


Running "build" task

Running "babel:dist" (babel) task

Running "coffee:glob_to_multiple" (coffee) task
>> 331 files created.

Running "prebuild-less:src" (prebuild-less) task

Running "cson:glob_to_multiple" (cson) task
>> 172 files compiled to JSON.

Running "peg:glob_to_multiple" (peg) task
Generating parser from "node_modules/snippets/lib/snippet-body.pegjs"...
Parser "/tmp/atom-build/Atom/resources/app/node_modules/snippets/lib/snippet-body.js" generated in 50ms.

Running "generate-license:save" (generate-license) task

Running "generate-module-cache" task

Running "compile-packages-slug" task

Running "set-version" task

Running "generate-asar" task

Done, without errors.
tester@ubuntu-MXC061:~/atom$ script/test
Node: v0.10.35
npm: v2.13.3
Installing build modules...
Installing apm...
Installing modules ✓
Deduping modules ✓
Running "output-disk-space" task

Running "download-electron" task

Running "download-electron-chromedriver" task

Running "build" task

Running "babel:dist" (babel) task

Running "coffee:glob_to_multiple" (coffee) task
>> 331 files created.

Running "prebuild-less:src" (prebuild-less) task

Running "cson:glob_to_multiple" (cson) task
>> 172 files compiled to JSON.

Running "peg:glob_to_multiple" (peg) task
Generating parser from "node_modules/snippets/lib/snippet-body.pegjs"...
Parser "/tmp/atom-build/Atom/resources/app/node_modules/snippets/lib/snippet-body.js" generated in 63ms.

Running "generate-license:save" (generate-license) task

Running "generate-module-cache" task

Running "compile-packages-slug" task

Running "dump-symbols" task

Running "set-version" task

Running "check-licenses" task

Running "standard:src" (standard) task

Linting files...

✖ 0 problems


Running "coffeelint:src" (coffeelint) task

src/command-installer.coffee
  ✖  line 73  Line contains inconsistent indentation  Expected 2 got 0

✖ 1 error

Warning: Task "coffeelint:src" failed. Use --force to continue.
Error: Task "coffeelint:src" failed.
  at Task.<anonymous> (/home/tester/atom/build/node_modules/grunt/lib/util/task.js:205:15)
  at Task.runTaskFn (/home/tester/atom/build/node_modules/grunt/lib/util/task.js:254:9)
  at Task.<anonymous> (/home/tester/atom/build/node_modules/grunt/lib/util/task.js:300:12)
  at /home/tester/atom/build/node_modules/grunt/lib/util/task.js:227:11
  at process._tickCallback (node.js:442:13)


Aborted due to warnings.

#3

Just a friendly note. See the section on “Code Blocks” in the FAQ here:


#4

I don’t get this error on the latest master. What version of Atom are you trying to build?


#5

I downloaded from git clone.

Here is given below

tester@ubuntu-MXC061:~$ python --version

Python 2.7.10

tester@ubuntu-MXC061:~$ git --version

git version 2.5.0

tester@ubuntu-MXC061:~$ node --version

v0.10.35

tester@ubuntu-MXC061:~$ npm --version

2.5.1

tester@ubuntu-MXC061:~ cat /etc/*release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=14.04 DISTRIB_CODENAME=trusty DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS" NAME="Ubuntu" VERSION="14.04.3 LTS, Trusty Tahr" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 14.04.3 LTS" VERSION_ID="14.04" HOME_URL="http://www.ubuntu.com/" SUPPORT_URL="http://help.ubuntu.com/" BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" tester@ubuntu-MXC061:~ uname -a

Linux ubuntu-MXC061 3.13.0-63-generic #103-Ubuntu SMP Fri Aug 14 21:43:30 UTC 2015 i686 i686 i686 GNU/Linux

tester@ubuntu-MXC061:~ cd atom/ tester@ubuntu-MXC061:~/atom git fetch -p
remote: Counting objects: 47, done.
remote: Compressing objects: 100% (47/47), done.
remote: Total 47 (delta 22), reused 0 (delta 0), pack-reused 0
Unpacking objects: 100% (47/47), done.
From https://github.com/atom/atom
e8b7a6b…b6a2646 master -> origin/master

  • [new branch] ns-test-build -> origin/ns-test-build
  • [new branch] ns-throw-when-adding-destroyed-pane-items -> origin/ns-throw-when-adding-destroyed-pane-items
    8acd324…4bc6999 tj-remove-deprecations -> origin/tj-remove-deprecations
    tester@ubuntu-MXC061:~/atom$ git checkout $(git describe --tags git rev-list --tags --max-count=1)

HEAD is now at 51ecbc0… 1.0.15

tester@ubuntu-MXC061:~/atom$ npm config set python /home/tester/Softwares/Python/2.7.10/bin/python2 -g
tester@ubuntu-MXC061:~/atom$ script/build

Node: v0.10.35 npm: v2.13.3

Installing build modules…
Installing apm…
Installing modules ✓
Deduping modules ✓
Running “download-electron” task

Running “download-electron-chromedriver” task

Running “build” task

Running “babel:dist” (babel) task

Running “coffee:glob_to_multiple” (coffee) task

331 files created.

Running “prebuild-less:src” (prebuild-less) task

Running “cson:glob_to_multiple” (cson) task

172 files compiled to JSON.

Running “peg:glob_to_multiple” (peg) task
Generating parser from “node_modules/snippets/lib/snippet-body.pegjs”…
Parser “/tmp/atom-build/Atom/resources/app/node_modules/snippets/lib/snippet-body.js” generated in 57ms.

Running “generate-license:save” (generate-license) task

Running “generate-module-cache” task

Running “compile-packages-slug” task

Running “set-version” task

Running “generate-asar” task

Done, without errors.
tester@ubuntu-MXC061:~/atom$ script/test
Node: v0.10.35
npm: v2.13.3
Installing build modules…
Installing apm…
Installing modules ✓
Deduping modules ✓
Running “output-disk-space” task

Running “download-electron” task

Running “download-electron-chromedriver” task

Running “build” task

Running “babel:dist” (babel) task

Running “coffee:glob_to_multiple” (coffee) task

331 files created.

Running “prebuild-less:src” (prebuild-less) task

Running “cson:glob_to_multiple” (cson) task

172 files compiled to JSON.

Running “peg:glob_to_multiple” (peg) task
Generating parser from “node_modules/snippets/lib/snippet-body.pegjs”…
Parser “/tmp/atom-build/Atom/resources/app/node_modules/snippets/lib/snippet-body.js” generated in 51ms.

Running “generate-license:save” (generate-license) task

Running “generate-module-cache” task

Running “compile-packages-slug” task

Running “dump-symbols” task

Running “set-version” task

Running “check-licenses” task

Running “standard:src” (standard) task

Linting files…

:heavy_multiplication_x: 0 problems

Running “coffeelint:src” (coffeelint) task

src/command-installer.coffee
:heavy_multiplication_x: line 73 Line contains inconsistent indentation Expected 2 got 0

:heavy_multiplication_x: 1 error

Warning: Task “coffeelint:src” failed. Use --force to continue.
Error: Task “coffeelint:src” failed.
at Task. (/home/tester/atom/build/node_modules/grunt/lib/util/task.js:205:15)
at Task.runTaskFn (/home/tester/atom/build/node_modules/grunt/lib/util/task.js:254:9)
at Task. (/home/tester/atom/build/node_modules/grunt/lib/util/task.js:300:12)
at /home/tester/atom/build/node_modules/grunt/lib/util/task.js:227:11
at process._tickCallback (node.js:442:13)

Aborted due to warnings.
tester@ubuntu-MXC061:~/atom$
tester@ubuntu-MXC061:~/atom$ cd
tester@ubuntu-MXC061:~$ . ~/Project/ENV/atom.env

tester@ubuntu-MXC061:~$ atom --version 1.0.15-51ecbc0

tester@ubuntu-MXC061:~$

apm --version

Fatal Python error: Py_Initialize: Unable to get the locale encoding
File “/home/tester/Softwares/Python/2.7.10/lib/python2.7/encodings/init.py”, line 123
raise CodecRegistryError,
^
SyntaxError: invalid syntax
Aborted (core dumped)
tester@ubuntu-MXC061:~$

I installed/updated the latest atom version i.e., branch - master but when I typed the command “apm --version”. It is showing nothing, so apm command is not working on the latest version. Can you know the problem how to fix?


#6

All of this is just a bunch of noise that isn’t helping anyone help you. Perhaps you should look at some of the other topics and how people have presented their problems?


#7

This is the error you have to fix. I assume that you changed something in src/command-installer.coffee because I do not get this error when I build from the latest master.


#8

Testing done. I have installed atom text editor and apm command. Both are working fine. The problem is resolved.


#9

Closing this topic since the issue is resolved. I’m glad it is working for you now :grinning:


#10