Building atom on windows 8 not working


#1

After I cloned the source to my desktop, I followed the instructions in the readme.md and the build instructions, but it doesn’t show up under my Program Files folder.

When I’m in the Git Shell and I pass in the “scripts/build” command, it doesn’t output anything so I’m not even sure if it ran successfully.

Can anybody help me troubleshoot this?


#2

Since you followed the instructions, I assume you successfully installed the right versions of node and python.
Can you try running script/build from Powershell, and show us whatever output you’re getting?


#3

http://imgur.com/L9axSmZ

This is all the output I get.


#4

What does node -v and npm -v give you?


#5

v0.10.31 and 1.4.23, respectively.


#6

Have you built it before by any chance? In that case it might be worthwhile running script/clean before script/build.

But you could also try running the build in a command window (elevated as Administrator) and see if that gives you some more output.

At any rate, you should at least see it give you the node and python versions it has detected and will be using, something like this (ignore that my cloned folder is called atomics, I get bored):


#7

http://imgur.com/WAoQPHi

:confused: nope


#8

This is the outupt I get just by running npm. I’m not sure if it’s related or not, but it was run just from the windows powershell.

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Program Files (x86)\\nodejs\\\\node.exe',
1 verbose cli   'C:\\Program Files (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js' ]
2 info using npm@1.4.23
3 info using node@v0.10.31
4 verbose node symlink C:\Program Files (x86)\nodejs\\node.exe
5 error Error: ENOENT, stat 'C:\Users\Christofer\AppData\Roaming\npm'
6 error If you need help, you may report this *entire* log,
6 error including the npm and node versions, at:
6 error     <http://github.com/npm/npm/issues>
7 error System Windows_NT 6.2.9200
8 error command "C:\\Program Files (x86)\\nodejs\\\\node.exe" "C:\\Program Files (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js"
9 error cwd C:\src\atom
10 error node -v v0.10.31
11 error npm -v 1.4.23
12 error path C:\Users\Christofer\AppData\Roaming\npm
13 error code ENOENT
14 error errno 34
15 verbose exit [ 34, true ]

#9

Not sure about this one. Something wrong with your node installation maybe?

I suggest opening an issue on the repo, see if the atom team can help out.


#10

I’d recommend trying to re-install Node.js. Today I was setting up a VM with Windows Server 2012 for a little demo, and while I was trying to start my simple project using npm start it crashed complaining about random things. Re-installing Node.js fixed my issues.