Bug: Hang on pressing spacebar

Hi there

Since the latest update Atom hangs when I press the spacebar and then unfreezes after 10 seconds or so, even when typing out a commit message.

Atom 1.51.0 x64
macOS 10.15.6 Catalina

Hi, I’m not seeing this issue on Atom 1.51.0 on macOS Catalina 10.15.7.

Do you have any community packages installed to Atom? Does this happen in safe mode?

It’s gone from bad to worse. It doesn’t even load a window now, even in safe mode. I see the loading cursor appear and then nothing shows. I go Window > Minimise, and it minimises an empty window to the dock.

I am using a Macbook Pro 13" mid-2012.

Hi again,

I recently went through a situation that seems a bit like what you are describing. I was maximizing and un-maximizing an Atom windows when suddenly it went entirely off-screen.

Are you able to open a new window, and if so, is that new window visible? (command + shift + N, or in the global menu, File -> New Window). Maybe that can work.

You can also try running from Terminal: atom --clear-window-state.

(Coincidentally, I am using the same year and size of MacBook Pro).

Ha, besides my problem with Atom, it shows how good a MacBook it is - they don’t make them like they did!

Anyway, I tried that atom --clear-window-state but it didn’t work. So I did a reinstall, which only made the window appear on first load.

I reinstalled it yet again so I could record the original issue (while in safe mode, I must add)…
Screen_Recording_2020-09-28_at_23.15.12.mov

You can’t see the mouse cursor, but you can see the caret freeze each time I hit the spacebar. The app also takes an age to close down and warns the application isn’t responding - I’m using a Samsung SSD, so it definitely isn’t the MacBook itself.

Thank you for taking your time out to look into this.

Hmm. Very strange.

If this can’t be figured out on this forum, then I suppose it should be posted as a bug here: https://github.com/atom/atom/issues/new/choose


One last thing I can think to troubleshoot this: rename the .atom folder that holds all the temporary/transient data (metadata, preferences, caches, installed packages) that Atom uses. Should make things run as close to a totally fresh install as possible.

If you want to try that, first quit Atom. Then, In Terminal:

cd ~
mv .atom .atom_backup

Then start Atom. (This creates a new, fresh .atom folder.)

Whenever you want to restore your old configurations and caches, etc., you can reverse the process (delete the “fresh” folder and restore the backup):

cd ~
if [ -e .atom_backup ]; then rm -rf .atom; else echo "no backup found! not deleting main .atom folder."; fi
mv .atom_backup .atom

Yeah, definitely odd.

I tried you suggestion, but unfortunately it didn’t make any difference. So I will open an issue on the Github repo.

Thank you for taking the time to help me! :octopus:

I managed to fix it!! :raised_hands:

An app I purchased all the way back in 2007 called AppZapper (the uninstaller Apple forgot) managed to remove all the Atom files include those under Application Support and elsewhere. I then reinstalled the app and it’s faster than ever! :smiley:

See I only dragged the app itself to the trash can before, which would have missed all the residual files!

Glad it’s working now - I can go back to using it again! :blush:

I somehow didn’t see your messages until today.

Congrats on the fix! :tada:

1 Like