Bug: Cmd-Shift-[Anything] not working


#1

Hey folks,

Just joined the beta and right out of the gates Cmd-Shift-P didn’t work. When I tried to Send Feedback, I got a blank grey panel and that’s it. Now it’s stuck there.

Note: Subsequent attempts to close and reopen atom result in a crash.

Cheers,
Darryl


#2

Did you try installing Atom again?


#3

Yes – tried installing it again and this time it launched without the welcome text and just an untitled file. Cmd-shift P just resulted in a capital P in the file. I tried installing it on a different iMac in the office and it worked perfectly. It seems there is something unusual about this particular Macbook Pro.

Darryl


#4

Just another update on this. After the reinstall, the ‘Send Feedback’ now works ok (updated title accordingly) but the Palette still does not. And it’s actually not limited to the palette, it’s simply that none of the keyboard commands do anything or have any effect. Pressing cmd-shift-[anything] results in the letter simply printing.


#5

Have you tried using the Keybinding Resolver? It can be brought up using ⌘.. The Keybinding Resolver will tell you what Atom thinks should happen when you press a key.

Can you bring up the Command Palette using the menus? View > Command Palette