Broken CMD+` window switching?


#1

OSX
Atom 1.7

In Atom 1.6, window switching worked well with

CMD + `

But when I updated to Atom 1.7, this breaks in a weird way.

  1. Switch from one window to another WITHOUT using Keyboard shortcut CMD + `
  2. Use CMD+` - It works.
  3. Use CMD+` again to switch back - It DOES NOT work.

A screencast of this happening - https://vimeo.com/162853087

I’m not sure if this is a problem with Atom. But for other applications, this seem to work - switching between windows.


Command to switch between windows
Command to switch between windows
#2

I can’t replicate this using Atom v1.9.0-dev-e230841 on Mac OS X 10.11.4. I also can’t replicate this using Atom v1.7.0 on Mac OS X 10.11.4. Here’s what I did:

  1. Launch Atom from the terminal using atom ~/Source/atom
  2. Launch Atom from the terminal using atom ~/personal-dotfiles
  3. Switch to the ~/Source/atom window using the mouse
  4. Switch to the ~/personal-dotfiles window using Cmd+`
  5. Switch back to the ~/Source/atom window using Cmd+`
  6. Continue switching back and forth between windows using Cmd+` a few times to ensure that it isn’t something that shows up after a few repetitions

Have you tried launching Atom in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

I was not able to replicate this after the first time. It happened after the update. I quit the application and re-opened and it never appeared after that.

Thanks


#4

I am having this same issue. I am able to switch to the next window until I reach the last window (the window at the bottom of the list in the Window menu). Once I’ve reached the last window I am not able to switch back to the first window using CMD + `. I don’t have this issue with any other application.

I restarted in safe mode and did not have the issue. I then restarted in normal mode and no longer have the issue. I’ll update here if it happens again.

OS X - 10.11.5
Atom - 1.8.0


#5

For me atom doesn’t respect Cmd+` - a shortcut that works in any other application.
Any way to fix that?


#6

Does this work for you?

'.workspace':
   'cmd-`': 'editor:select-line'

Make sure you only have one .workspace selector.


#7

Take a look at the above suggestions and see if any of them help. I’ve been testing this keybinding repeatedly using Atom v1.8.0 on Mac OS X 10.11.5 and it works properly. Also, when reporting a problem, please include if you followed the suggestions in the Debugging document and the following information:

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#8

I find that if I use my laptops built-in Mac US keyboard then this works however, if I switch the keyboard preferences to my external British - PC then it stops working.

This appears to be something related to the keyboard map, as if I use the external British keyboard and the US keyboard mapping and then perform the CMD+` sequence using the key that the Keyboard Viewer shows as the ` key ( | next to the left had shift key) then the window switching works.


#9

I don’t know of a command / keybinding at all on linux, and I don’t think we have one, so I have a few questions, the later two could be answered by any mac user.

  • For you, can you confirm you are on mac in both cases?
  • In command palette, is there a command entry at all? (cmd-shift-p)
  • On success, in keybinding resolver, what is the command called? (cmd-.)

As far as my help, I can provide you a custom command and let you bind it. If you already have a command but are unable to bind it where you want… I may not be able to help : (


#10

The Atom FAQ, has an entry on problems with non-US English keyboard layouts:

I’ve heard people report that this Cmd+` problem can occur on British English layouts and that the keyboard-localization package has worked for them.


#11

cmd + ` does not work for Japanese keyboard, instead, cmd + F1 does work for all app except for Atom.
senebier can solve this.
However, I really want to do it in the most simple way :disappointed: .


#12

See my post here:


#13

I have the same issue, running atom 1.17 and MacOS 10.12. It can reproduce in safe mode. Using keybinding resolver can only capture cmd when I press cmd+`.


#14

BTW:

  1. I set atom to open new window as tab, like this:
  2. I am using US-style keyboard.