Brackets Matcher Glitches


#1

I have been using atom a while now. It actually has almost all the features I want while developing and a strong community. However; I have a problem with the brackets matcher using " or '. On the first press of I get something like in the image (1). Then on the second press I get this (2). I am using Atom(1.19.0 x64) on Mac.

I installed Atom (same version) on a Windows, but this problem is only present on Mac.

If you don’t understand what I mean with my problem. I mean that when I press " or ', I should get two and the cursor should be inside the two quotes (either single or double), as I get on Windows.

I’ve tried this Debug, but it seems it doesn’t solve any problem.

Any help is so much appreciated.


#2

What happens when…?

  • press spacebar in situation (1)
  • there is a space before > and you press "

  • Is your Mac set-up for multi-language support or only US / English?

#3

I have multi-language support. English and Arabic.


#4

I have no idea if this is the cause and I do not use a Mac.

What I do know from working with others’ Windows PCs that has multi-language support,
where this happens for example:

  • type "
  • type e
  • result: ë

#5

Actually this is true. This happens when I type " + e = ë. Is this the problem?


#6

I’ve changed the keyboard input source from US International-PC to US and it solved my problem. This is so weird! Because this problem is present only in Atom.io not with Brackets.io nor with Sublime Text.


#7

Thanks a lot. You saved the day :slightly_smiling_face::slightly_smiling_face:


#8

Hi.

That is good news! Thanks for the feedback.

It is an interesting problem. Some might want the functionality you have seen. I invite you to log a request for the guys to look into this one - I think the at the Atom’s core, not the brackets add-in. What proposal to make, I am unsure of too. Perhaps have some user selectable to force the system to subdue the multi-language support when not writing text / markdown files.

Regards.
dP


#9

Hey,

We fixed some text input bugs in the hotfix releases. Can you try to update to Atom 1.19.3 to see if you still have this issue?

I am unsure about how macOS is expected to work with these steps because I have never used a mac but it doesn’t sound right since other applications work differently.


#10

I have updated to 1.19.3 and left the keyboard input source to be US International - PC and the problem still persists in the latest version.


#11

I’ll log a request to developers to take care of this problem in the next update.


#12

@Tes3awy: Thank you for your willingness to help!

@Ben3eeE: Any further instructions for our friend on where to log the behaviour and what to look at for his report?


#13

@Tes3awy I’m seeing the same behavior on sublime text when you have US International-PC set. I believe this is intended behavior. It’s easy to get confused with which language you have selected because the application will use the one you last selected.

I’ve tested this on Sublime, Atom, VSCode and Bracket with US International
Atom and sublime text behave the same - Highlights the first quote, if you hit space will create a matching bracket. If you hit the same quote key again it will create 3.
sublime

Bracket and VSCode behave the same - Doesn’t do bracket matching.

If you set it to US everything seems to work as expected.


#14

Brackets lets you type the quotes without inserting a third one in between. However; Using Sublime Text 3, I didn’t experience the problem when keyboard input source isUS International - PC. Actually changing the keyboard input source is not a solution as I want to be US International - PC for my own needs.


#15

Welcome.
Very nice glimpses you made for us.
Thank you for joining us and sharing you investigating and feedback.


#16

I had a quote font issue on Mac once. It was solved by doing System Preferences > Keyboard > Text and de-select Use smart quotes and dashes. Not sure it helps in this case though