Bracket & quote auto-completion


Is it possible to somehow prevent the Atom to complete the second bracket or quote, if it already exists? For example, when I have:

else }

and I type an opening curly bracket after the else statement, I end up with this:

else {}}

The same situation is with quotes and all other types of brackets, which is really annoying.

I tried smart-tags package, but it doesn’t work in combination with core bracket-matcher package. Please note, that I don’t want to disable completion, just to make it smarter.


I have just noticed the similar annoying behaviour when deleting brackets. For example:


After deleting the bracket after bar:



I believe these are already reported on the bracket-matcher package, but I can’t find them right now. You may want to take a look at the open issues and subscribe to the ones that interest you or if you can’t find it open a new one.


Thanks for your response. I also wasn’t able to find exactly this issue so I created a new one.