Bracket-matcher autocompleteCharacters settings for .gfm.source


#1

I am trying to auto-pair * and _ (for emphasis and bold) in markdown. The following settings do not produce any change (when I type *, I still get *| while I expect *|*).

".gfm.source":
  "bracket-matcher":
    autocompleteCharacters: [
      "**"
      "__"
    ]

I tried escaping the star and underscore but it didn’t help. The scope seems to be right, since changing other bracket-matcher options for .gfm.source works fine (I tried autocompleteBrackets: false and as expected, autocompletion was disabled for markdown).

What am I doing wrong?


#2

Because the custom pairs feature isn’t implemented yet in the version shipped as core in base Atom (even though the update was made months ago). Check the settings page on the bracket-matcher package in your Atom and scroll all the way down. That’s the readme.md that existed at the time it was shipped. If you want, you can always download or clone the repo into .atom/packages, run apm install, and then reload Atom in order to override the core package with the latest version of itself (if they have the same name, the one in .atom/packages will get used). Then when the Atom team updates the version used of bracket-matcher, you can delete that folder and Atom will revert back to the one inside it.


#3

Thank you ! I tried to clone the repo, but I had to install two more dependencies (first-mate and underscore-plus) and it kept throwing an error “Module did not self-register”. I think I’ll wait for the update.