I have cloned the repository and launched
script/bootstrap. The first lines of the progress report say
Installing script dependencies
node 10.2.1 x64
node-gyp -v is 6.1.0. Upon installing the modules, this error occurs
gyp ERR! configure error
gyp ERR! stack Error: Python executable “/mnt/sda2/lipari/s/atom/atom/apm/node_modules/atom-package-manager/bin/python-interceptor.sh” is v3.7.4, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
So basically node-gyp wants Python2, but I don’t know where exactly I should pass the --python switch as suggested. If I then go to node-gyp page at https://www.npmjs.com/package/node-gyp I pick this suggestion that
node-gypis called by way of
npm, and you have multiple versions of Python installed, then you can set
npm's ‘python’ config key to the appropriate value:
$ npm config set python /path/to/executable/python
I then do
npm config set python $(which python2) — check that the file ~/.npmrc returns “python=/usr/bin/python2” — for good measure
. ~/.npmrc — to no avail. Same error bootstrapping.
How can I avoid this error and bootstrap atom successfully?
Working with Debian GNU/Linux 10 (buster)