Blurry Text on Windows/Low-DPI


#1

Atom 0.121 shows extremely blurry text on Windows 8.1 (125% dpi):

Any idea on how I can fix that? Is it possible that the window is somehow zoomed?


#2

Atom 0.120 looked better:


#3

What if you switch back to 100% DPI, i.e. no scaling?

Note that the latest atom version comes with an updated atom-shell as well, which uses Chromium 36, which in turn now supports high DPI screens, so scaling shouldn’t be necessary anymore.


#4

It may be also related to:


#5

I’m seeing the same on Linux as well, v122:

Not a high DPI screen either.


#6

Then it looks like 0.120 (better) but I can’t use it at that size.

Not sure I understand - is there a scale setting in Atom? I was talking about 125% in Windows, Control Panel, Display, which I need for all apps. I can’t turn that off.


#7

Well Atom is using Chromium for low level rendering of web technology. Chromium v36 (which Atom now comes with), has explicit high DPI support.
On high DPI screens that means Atom text might look drastically different (for me it blows up to some huge size, but it is also sharper).

And I suppose it looks like on normal DPI screens, but with forced scaling, there might be side effects as well.


#8

@batjko My screen is only ~1600x1000 (VM) running on a MacBook, no high dpi.

btw, there is also a difference between Win 7 (better) and 8.1 (worse).

Are there any Atom settings to control the text rendering?


#9

I have been wrong before, but Atom doesn’t control rendering on that level, I don’t think. This comes from the Chromium that’s being used.

Don’t Macbooks all have high DPI screens nowadays? Retina n’stuff?

http://support.apple.com/kb/HT5266: Scroll down to the last question regarding Win7 and small icons (due to DPI scaling).


#10

Only the newest (mid-2012 till now) MacBook Pro machines have Retina displays.


#11

Just updated and the blur is across the entire workspace. It is pretty bad, I am going to just revert back to 1.20 in the mean time.


#12

Have any of you looked at the other topics related to font rendering on Discuss already? Such as:


#13

Yes but you can use the VM either with our without Retina.

  • I’ve switched Windows 8.1 to Retina at 250% dpi (3200x2000) and the text is now crisp in Atom, perfect.
  • Windows 7 can’t use Retina though (not supported).

So the issue is only present on low-dpi displays.


#14

@leedohm thanks but the text still stays blurry.


#15

Yes, I was wondering whether that’s the case. I haven’t had a chance to test it out on both.
Well that’s a shame, but it’s a reason to use my shiny laptop more often out in the coffee shop, rather than sitting at my dirty old desk. So it’s a good thing.


#16

Windows Registry editing fixed the font thickness issue for me completely, we can tune the font thickness/darkness by calibrating FONTSMOOTHINGGAMMA value to between 150 and 190 hexadecimal( 336 to 400 decimal )

-     START  ->  RUN  ->  REGEDIT
-     search for  FONTSMOOTHINGGAMMA   by  keying  " Ctrl F "  ( will automatically take us to  CurrentUser\ControlPanel\Desktop  path)
-     double-click mouse on  FONTSMOOTHINGGAMMA    enter anything between 150 and 190 hexadecimal.(the Lower the value, the thicker the fonts.)
-     close the REGEDIT tool
-     LOGOFF and then LOGON

Now all the fonts are very thick & very dark in Chrome Browser.

But we must make sure that ClearType smoothing is enabled in Windows( controlPanel -> personalization -> appearance -> Effects -> ClearType smooth check [ ticked box ] )

                     OR  alternately in RegEdit ...

         FONTSMOOTHING=2
         FONTSMOOTHINGTYPE=2
         FONTSMOOTHINGORIENTATION=1  for LCD-screen,  0 for CRT-screen

#17

I can disable Chrome’s blurry font rendering with chrome://flags/#disable-direct-write, how to access that flag from Atom?


#18

I fixed blurry fonts problem by adding /force-device-scale-factor=1 to shortcut.
UI is now very small, but at least fonts are not blurry.

"C:\Program Files (x86)\Spark Dev\atom.exe" /force-device-scale-factor=1

#19

Any other workarounds for this?
I’m not sure you can see it in the screenshots, but the word “config” on the left is much sharper than the coloured code on the right.

This is on 1.0.19 on Windows 10, on a “low DPI” screen.


#20

Any ideas @raelyard?