Blurry text on Windows High-DPI


#1

Atom 1.11.2 has really blurry text on my 1920x1080 Thinkpad T460s display. I’m running Windows 10 with 150% scaling. The only thing that fixes the problem so I could work with Atom is adding black shadow to the text.

atom-text-editor {
text-shadow: 0 0 1px black;
}

Without using shadow:

Any ideas on how to actually fix this ?


#2

This was on the Twitter feed for new packages today, maybe give it a shot:


#3

Too bad but this is not fixing anything for me.


#4

Having the same issue - it’s been two years of posts on this, and Atom still doesn’t show any interest in fixing it. The antialiased plugin does nothing. I’m on an xps 13 with the normal 1080p screen. The only way around it is to disable display scaling via the shortcut command line and then change the font size in the editor, but then the menus are freaking tiny.

with 150% windows display scaling, default font size - impossible to code without your eyes burning

with 150% windows display scaling, default font size


#5

with display scaling disabled, increased font size (tiny menus)


#6

Electron 1.4 makes all text subpixel antialiased on Windows (at least for me). We’re currently working on moving Atom to that Electron version.

Just so you know, there’s nothing that Atom can really do other than upgrade Electron, since it’s the underlying Chromium build that determines whether to subpixel antialias things or not. Occasionally there’s scenarios where some CSS properties disable subpixel AA (https://github.com/atom/one-dark-ui/issues/191), but more often than not the big changes come from Chromium.


#7

right, it’s just that it’s 2017 and there are more scaling displays out there than not. might be time to sort this out.


#8

An app called “XPExplorer - Windows 10 DPI Fix” solves this problem by reinstating the old Windows 8 method of DPI scaling. Start up the app, check “Use Windows 8.1 DPI Scaling”, and choose your scaling level. After you click Apply, it’ll ask you to reboot. When you come back, fonts in those apps should be clear once again. To revert to Windows 10’s method, just re-start the app, check “Use Windows 10 default DPI scaling”, and reboot your computer twice. Check more details at Dell XPS 13 Manual.


#9

I found this init script hack useful to synchronise UI font size with editor font size: https://github.com/atom/atom/issues/11905#issuecomment-225068527