Bangla language texts not showing in editor


#1

Hi,
Great editor. I just started using Atom. But at the first time I got into a problem. Bangla texts is not showing on the editor instead its showing some boxes, you know. I am using utf-8 file encoding. Isn’t it support unicode yet ? It would be very helpful if anyone can give me a solution.


#2

The font you’re using probably doesn’t support Bangla (yet)… To fix this, you’ll have to find another font that supports Bangla and use that on the text editor, or if you like the font you’re using right now, you can follow the procedure I outlined here to use only a subset of the Bangla font. You’ll have to replace the unicode range there with the one for Bangla, which should be 0981 - 09FA.


#3

Maybe it is as easy as selecting a font that supports this character set. I know nothing about Bangla but I have a hunch that the default font might not support it.


#4

Thanks @olmokramer and @kgrossjo , perfectly worked.

Let me tell how I did this after your suggestion.

At first I added this bangla font:

@import url(http://fonts.googleapis.com/earlyaccess/lohitbengali.css); 

Then under settings tab on font family field I added this font:

Lohit Bengali, sans-serif;

Thats all.
Thank you again.