Bad text rendering in Atom because of Freetype library


#1

Hello there
I recently encountered some problems using Atom on my computer, working under Linux. As you can see on the screenshot below, weird blue lines and dots appear next to my beautiful code’s characters (and even in the tree view). Besides, those lines appear nowhere else on my computer.
I have really no idea where this bug comes from, since it does not depend neither on my theme, nor my font family.


Those dots and lines are visible between the ‘l’ and the ‘u’ in the include line, or in the middle of the word ‘char’ on the second line, etc.

I know it is quite discreet but I grant you this is really disturbing while typing some code. I tried to make a new fresh install but this didn’t solve the problem. Have you any idea?

Thank you,
Loutr
(I apologize for the mistakes I may have made as a non-native english speaker)


Editor font plays weird
Random noise in editor
#2

Hello.

Reading your question on my mobile - I thought it was something to do with the display of “invisiblles”. Looking on the PC…

That looks like a rendering issue… ouch!

Which version of Atom are you running?
For how long was this behaviour like this?


#3

Hi @loutr,

Are you using freetype 2.8.1? There is an open issue for this that looks similar to what you are seeing. In the issue comments there are instructions for how to downgrade to freetype 2.8.0 and everyone reports back that the font rendering is correct after downgrading.

https://github.com/atom/atom/issues/15737


#4

@danPadric thank you for replying that quickly :slight_smile:
This behaviour appeared this afternoon, since the last update I made from the 1.21.1 to the 1.21.2 version of Atom.

@Ben3eeE, I think you have pointed out the right thing! This seems to be due to the Freetype font rendering library, which causes some troubles once updated to version 2.8.1. Thus, I downgraded it to the previous version taken from the Debian Snapshots Mirrors (as this version is no longer available on the Testing mirrors), as said in the request you gave me : everything is working, my meh is now perfectly displayed!
Meh

According to the same topic, this issue will be fixed on the January’s release of Atom.
Thank you a lot :smile:


#5

Hey @loutr,

This is a very optimistic guess. The reality is that we can not know when we will release a version of Atom based on Chromium 62. It’s our policy to never promise dates on when things will be fixed, merged, or shipped until it is fixed, merged, or shipped, respectively.

When something has been merged we can mention the specific version of Atom where it is scheduled to be released. But even then it happens that we revert something before shipping because we notice issues while testing and have to delay the release of that specific feature or bug fix.


#6

@Ben3eeE OK, I didn’t know about the project’s policy; this release date is just something I quickly saw while looking for my problem’s solution :slight_smile:


#7

Hi, this workaround worked for me (on Debian) from https://github.com/atom/atom/issues/15737

in .atom/styles.less:

atom-text-editor {
  transform: scaleX(1.0000001);
}

#8

It worked so much!!! Thanks! :stuck_out_tongue_closed_eyes: