Babel + JSHint



I’m using the babel-language package but I notice that the linter-jslint is not taken in place anymore. How can I enable jshint also for babel js files?



JSLint applies to the scope source.js.jsx, which matches the scope of the Babel package. For JSHint, the JSX compatibility is activated by a config setting on the package. Open up your Settings pane, go to packages, and click right in the middle of that block (any area that’s not a button or link elsewhere goes to the page for that particular package). You’ll see the configuration options.


Sorry, but I didn’t understand if the two packages should work together or not. Anyway, if I open a js file, that is recognised as babel, the jshint is not executed.


Have you changed the setting?