Autosave doesn't work on windows box


#1

I am using atom and I’m trying to get autosave to work. It’s in the packages, enabled, and has the check box enabled. It just never saves till I hit ctrl s on each file.

Here is some relevant info:

I’m running on windows 10
My code is not local it’s ssh’d in from a vm
I am also using nuclide, although, I don’t believe that would interfere with saving files.

Save all works from the menu but I can’t assign a hot key to it. I will post about that in a separate thread.
Thanks


#2

The autosave package only saves when the editor loses focus (you have it active and click away from it) or the editor is closed, and I just tested it (Win 10, Atom 1.23.3) and it behaved as expected. Does the save not happen when you click away from the editor? Does it happen when you’re working on a local file?

Please share what you have added to keymap.cson.


#3

ah, it does seem to work on local files. on remote files it never auto saves no matter what I do.
As for the key mapping that is an other big issue for me. Here’s how I described it on stackoverflow

I’m trying to get somehot keys assigned. Some work, some don’t. From what I can tell if there has not been an action previously assigned to a hotkey then it’ll work.

Here’s what I think would help, if I could un-assign actions form hotkeys, just clear it all out, then assign what I want. Also if there is a list of all available actions that can be assigned and the sort of syntax or namespace for them that would be great.

the save all hot key which is the only one I tried to do myself ( the rest were from the intellij-idea-keymap) looks like this

This file uses CoffeeScript Object Notation (CSON).

If you are unfamiliar with CSON, you can read more about it in the

Atom Flight Manual:

http://flight-manual.atom.io/using-atom/sections/basic-customization/#configuring-with-cson

‘body’:
‘ctrl-shift-S’: ‘core:save-all’

that’s the whole file, that’s why I included the comments to show the beginning.

So to recap,
a) here’s my problem with keybindings
b) is it possible to get autosave to work with remote files?
Thanks a lot for your help
R


#4

wow, sorry about that. mark down I guess


#5

There’s documentation about that.

Also if there is a list of all available actions that can be assigned and the sort of syntax or namespace for them that would be great.

And also that.

the save all hot key which is the only one I tried to do myself ( the rest were from the intellij-idea-keymap) looks like this

When posting code, remember to highlight it and click on the </> button above the editor to mark it as code. I can’t tell if your keymap is valid because you didn’t preserve spacing.

b) is it possible to get autosave to work with remote files?

What package are you using to access the files?


#6

Ok awesome, I"m sorry, I’m learning a ton of new stuff during a ramp up and I guess I forgot to RTFM. So thanks for the links.
The keybinding looks like this
’body’:
‘ctrl-shift-S’: ‘core:save-all’

hope that worked.


#7

ok struggling. basically ‘body’ is at char 0 and 'ctrl… is at char 2. so to spaces.
I’ll try to past again.

'body':
  'ctrl-shift-S': 'core:save-all'

aha, the icon doesn’t work but 4 spaces does. sorry about that.
r


#8

According to the Command Palette, there’s no core:save-all command. Instead, there’s a window:save-all.


#9

that would be a problem. this has been super helpful, haven’t had time to read the docs you sent me don’t know where I got that syntax. But I can see my way to a much better workflow now.
Thanks a lot!
R


#10

If you saw core:save somewhere, it would be a sensible assumption that core:save-all is a thing.


#11

oh, re: remote files, we are using something called nuclide I didn’t know that was responsible for setting up remote access, but I guess that would make sense.
R


#12

I haven’t used Nuclide, so I don’t know anything about how it works with remote files.