Automatic updates no more supported

Since few time, on a Windows 10 install, it seems that I can’t check anymore for updates of Atom core when I open the About tab.

atom-about

As I know my system had have supported checking automatic updates previously, I have searched in %USERPROFILE%\appdata\local\atom\squirrelsetup.log to check exactly when some prior proceedings have been done:

2018-07-31 [...]> FileDownloader: Downloading file: https://atom.io/api/updates-x64/atom-1.28.2-full.nupkg
2018-08-08 [...]> FileDownloader: Downloading file: https://atom.io/api/updates-x64/atom-1.29.0-full.nupkg
2018-11-22 [...]> FileDownloader: Downloading file: https://atom.io/api/updates-x64/atom-1.32.2-full.nupkg

Does anybody know what can have changed? Can it be due to Windows 10 recent upgrades or to any releases I missed in the Atom version history?

You might try deleting the AppData/Local/atom/ folder and reinstalling. I’ve had Atom get “stuck” at a previous version before, and the updater definitely still works on my Windows 10.

So, I followed your advice, and after removing my \AppData\Local\atom folder, I have reinstalled Atom (after waiting quite a long time because of slow download speed, by the way), this time with the last up-to-date release (ie. version 1.34). All seems to have been correctly processed, and that’s a good start.

But, nevertheless, I still get the same message in the About tab, asserting my “system does ot support automatic updates”…

34

Would I have missed any changes in the settings?

In a very weird way, after several relaunches of the software, the option to check for updates has just appeared back. I’m a bit confused and don’t know what to think…

:confused:

0

I don’t know why that would have happened.

This was a regression that should be fixed in the next releases (1.35 and 1.36 beta):

It happened if you had Automatically download updates unchecked.

2 Likes

Thank you for this information.
I was going to answer to @DamnedScholar to say that I couldn’t open an issue on GitHub because I didn’t really know how to reproduce the problem.