Automatic scroll disable?


#1

When using the editor, sometimes I click to select a set of text at the very top or bottom of the window. Atom’s default behavior when the cursor is in, what looks like, the first or last 3 lines of the screen, it will automatically scroll to show those 3 lines. So, if I click to start selecting and don’t even move the mouse, it just starts selecting like crazy!

Any idea on how to disable this sort of behavior?


#2

That feature is what is referred to in the book “About Face” as a “scroll veneer”. It is built for people who use mice without scroll wheels or other scrolling features. The behavior you’re running into is a bug. Typically it is desired to disable the activation of the scroll veneer if the mouse is clicked and either doesn’t move or only moves within the veneer area.

If you have a solid repro (that works in atom --safe), please file an Issue on atom/atom and post a link to it here. Thanks!


#3

I’m getting the same in Atom v0.194.0, also with --safe. When I mousedown on the topmost visible line, then the text jumps 2 lines. When I then move the mouse at least 1 pixel, while keeping the mouse button pressed, the editor starts to scroll like crazy and selects heaps of text.

I tried some things, but didn’t get it to work :frowning:


#4

Thanks for the clarification on terminology, @leedohm! Totally makes sense. I’m not sure what the desired behavior would be, since for my uses I would like it to not veneer any scrolling :smile:

I’ll run the test with --safe as soon as I get a chance and will post a report.


#5

Just posted the issue!