Autocompletion disabled for .* files?


#1

Dear GitHub Friends,
firstly many thanks for the great job and the very prolific community.
I am a newbie at using Atom, but I have encountered a certain issue
I could not find a reference about on the web.

I have created a new “.bashrc_profile”. When I start editing it,
it appears that for example autocompletion gets kind of disabled.

It appears that the package itself is active at all times, and checking
on other files without dot prefix it works properly.
So my issue is the following:
is it a feature to be expected on “.*” files, or is it a problem with my
Atom installation (the most recent version for MacOs High Sierra .6)?
Many thanks.
Best wishes.


#2

If you look at Settings -> Packages -> autocomplete-plus -> File Blacklist you’ll find the default match is .*. You can change this default, and presumably it will work on the .bashrc_profile file now.

Tangentially related is a big gripe I have with the current settings, which do not allow specifying lack of value; if you delete .*, it will assume you want the default and just come back. Instead, try replacing it with FOO (and remember this if you ever make a file called FOO).


#3

Dear Mr Gray,
Many thanks.

This solves the issue.

It works flawlessly now.

Best regards.