Autocomplete when i press tab


#1

Hello,

I am new to atom and when i write 'void" and press tab, when i create a function it doesnt do a tab. it autocomplete something for me :

void name(/* arguments /) {
/
code */

i can’t put a tab between the void and the name. it put a space when i would like it to be a tab. I just want ‘void’ ‘tab’ Could someone please help me? Thank you.


#2

You can cancel the autocomplete popup with esc, and then you can use tab normally.


#3

Strangely I could not get that to work.
I have even tried messing around with the autocomplete settings… this case just does not seem to get solved that way.

@zamehan: My brute force suggestion:

# init.coffee
'atom-text-editor':
  'tab': 'user:tab'
atom.commands.add 'atom-text-editor',
  'user:tab': (event) ->
    editor = @getModel()
    editor.insertText("\t")

I would suggest binding to something like Shift+Tab.

…or were you hoping to get indenting?