Autocomplete "show on keystroke" does not work


#1

After upgrading to Atom 1.19.0 the package autocomplete-plus does not work as expected (while typing) and the only way to trigger it is manually by the command palette or key-bind.

I double checked all the related packages and settings and everything looks fine.

To be sure is not related with an specific language I tried to get autocomplete-snippet to work, it does not either.

I also tried restarting several times.

This is IMHO a critical bug, basically “intellisense” functionality is broken for every kind of buffer.

(MacOS v10.12.4)

Thanks.


#2

Does it show anything when you have started Atom from the Terminal with atom --safe?

You can also test to make sure that it’s the update by going to the 1.18.0 releases and downloading atom-mac.zip. It will give you an executable Atom without installing anything, so you can try the two versions side-by-side.


#3

No warning with atom --safe


#4

Downloaded v1.18.0 as standalone, autocomplete works as expected.

So is a v1.19.0 specific issue.