Autocomplete-plus, sometimes return key doesn't work properly


#1


It sometimes doesn’t complete the word, but make new-line.
In most case, the first word is completed well, but next word is not.

How can I fix this?


#2

What happens if you press tab instead of enter?


#3

tab works well, but I use enter because of my habit… ;o;


#4

Do you have emmet installed? It seems to be the problem for a lot of people recently.


#5

No, I don’t.
And I’ve found that tab key is also not working properly like enter key.


#6

What do you see when you have the Keybinding Resolver (ctrl-.) open and try to activate autocomplete?


#7

I’m having the same issue, which is really annoying because it appears to happen randomly. Here is what I see in the Keybinding Resolver when it happens.

In case it’s working there is autocomplete-plus:confirm at the top, which is missing here.

Disabling emmet didn’t help, but it seems like the issue is not happening anymore if I disable all linter packages.


#8

I have this same exact issue, Unfortunately, I do not have any linters installed, I did at one point but they have all since been removed. This issue drives me crazy… Any fix to this that you are aware of besides the linter issue?


#9

So I found out why this was happening for me.

The plugin “Activate power mode” caused this issue for me.