Autocomplete Plus - Minimum Word Length not working


#1

The Autocomplete Plus package has a setting: Minimum Word Length.

I’ve tried setting it to 3, 5 etc. so that suggestions will only pop up when I have typed that number of characters, but for some reason, the suggestions pop up after I have typed a single character.

I’ve reloaded the page, restarted Atom, but I always get the same issue. For example, if I’m in a PHP doc and I type ‘a’ I instantly see, a, array, abbr, area, etc.

Any thoughts as to why it does this?


#2

Additional Information: I’ve disabled all Community Packages and it still does the above. Could it be because the “Show Suggestions on Keystroke” preference doesn’t respect the Minimum Word Length but always pops up the list after a single character?


#3

From what I gather, It should works with default symbol provider, but other provider should implement it themselves. Does it happens for every languages or just some ?


#4

It seems to happen with every language. I tried disabling all the providers I could find then re-enabling them, and in each case as soon as a match it found after one letter, the pop-up appears.