Autocomplete plus key not working


#1

For a while now the key for confirming a suggestion hasn’t been working in my Atom editor. No matter whether I set it to or or both in the settings of the autocomplete-plus package, when there are suggestions these keys simply do what they’d usually do, which is inserting a tab and inserting a new line.

What could be the reason for this behavior and how can I fix it?

It might be another package, but how do I provide a list of all installed packages?

EDIT

  • My Atom version is: 1.2.4
  • My OS is Xubuntu 14.04
  • Emmet is not installed.
  • When running atom --safe the issue is not present - I guess it’s packages then?

EDIT
The debugging page helped me find the issue. It seems the markdown-writer binds the key (enter for example) to insert-newline, which somehow takes precedence over confirming an autocompletion suggestion. Since I am writing a markdown document, I tried it in a normal document with no language specified and guess what, everything worked correctly.
So the solution would be to somehow lower the precedence of the markdown-writer package keybinding. How could that be achieved?

EDIT

(adding images to visualize the issue)

When typing text, which triggers an autocompletion suggestion:

http://postimg.org/image/4otutwsnr/

After pressing enter:

(new users can only add one image per post, sorry for that)

EDIT

The author of the package responded quite quickly and already told me how to circumvent the issue:

  1. disable markdown-writers keybindings
  2. Insert the following into your keymap.json:

“atom-workspace atom-text-editor:not([mini]):not(.autocomplete-active)[data-grammar~=‘gfm’]”:

“enter”: “markdown-writer:insert-new-line”
“tab” : “markdown-writer:indent-list-line”


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

Didn’t know about the debugging document. I’ll improve my question thanks!


#4

Updated my post with relevant information from debugging : )


#5

You can go into the settings for the markdown-writer package, disable the bundled keybindings and then bind your own copies of them. I can’t tell you specifically how to “lower the precedence” because it depends on why it is taking precedence and other stuff.

Really though, this should be fixed in the markdown-writer package. Have you reported a bug there?


#6

Haven’t yet, but I’ll do that : )