Autocomplete issue when trying to add an <a> tag in between two <li> tags


#1

When I’m adding a tag inside another tag, especially noticeable when adding un-ordered lists of links, I am not able to tab complete, or autocomplete the tag. Is that intentional? Why is that the case? Any help or troubleshooting by others would be much appreciated. Thanks!

I’ll include a photo of what I mean:

When I try to type an tag and tab complete, it doesn’t work. It shows a different menu it looks like:
a


#2

Here’s what it looks like when I AM able to tab complete or autocomplete:

li


#3

But what happens when you press tab after that menu shows up? It is the same menu, just with different options. What happens when you type a outside of li tags?


#5

I’m using LI’s and A’s because that’s the time I notice it the most. If I’m not trying to nest the tag directly inside another one, then I get the green menu and it works fine. If I’m trying to add the element directly inside the parent element with nothing else currently inside that parent element, then I get the blue menu and it doesn’t allow me to tab complete.


#6

What autocomplete packages do you have installed?


#7

The autocomplete packages I have are called autocomplete-atom-api, autocomplete-css, autocomplete-html, autocomplete-plus and autocomplete-snippets. I thought I read somewhere it’s the standard one that comes with Atom.

Wes


#8

Hi!
I had same problem that you have or had, and I solved it.
I write a way when I solved the problem.
Here are some tips for you.

select “Edit” > select “Select Grammer” > type “html” and select “HTML”

I hope this can be your help