AutoComplete from Buffer Not Working


#1

I installed the latest Atom on Windows and i don’t get autocomplete behavior, even if I start typing a word and use ctrl-space - I don’t see a dropdown of matching words from the buffer. I turned off VIM-MODE and it still doesn’t work.

The behavior I expect is that I start typing and after a few keys it shows me matching words from the buffer


#2

Do you have Enable Built-In Provider selected in the autocomplete-plus package settings in Settings View?

You can get to the Settings View by using Cmd+, on OS X or Ctrl+, on other platforms, then select the Packages tab on the left of the Settings View. Click the Settings button on the autocomplete-plus package to see its settings.


#3

Okay, still weird.

  1. started atom in atom -safe mode
  2. made user enable built in provider was set
  3. opened text file - no autocomplete behavior

If I open a “real” file like “.css”, it works fine.


#4