Autocomplete for ' and " (quotes) not working in fresh install


#1

Just installed Atom (1.12.7) fresh on a mac and Bracket Matcher (0.82.2) does not seem to work as expected on ’ and ".

Expected: If I type one quote, another is autocompleted and cursor is between.

Current behavior: Only the one typed is displayed and no autocompleting. [, { and ( seems to work as normal, but not ’ and ".

I was not able to find any settings changing this behavior to the expected (as experienced from other installs I have, where Bracket Matcher autocompletes quotes “out of the box”). I have tried to put this list in config.cson:
“bracket-matcher”: {
autocompleteCharacters: [
"()",
"[]",
"{}",
"<>",
"""",
"’’"
]
}


#2

I don’t know why it’s not working for you on quotes, but autocompleteCharacters doesn’t do anything yet. That’s in a newer version of the package than the one you have (it’s in 0.85.x).

Try starting Atom from the command line with atom --safe and see if it’s still not working.


#3

Safe mode does not help…

Any other information I can give to help narrow this down. No one else having this issue?


#4

Have you followed the suggestions in the Debugging document? Specifically the section on resetting Atom to factory defaults?


#5

Thanks a lot for trying to help. As I said the install was fresh, but tried mv ~/.atom ~/.atom-backup, as stated in the debugging document to reset atom. Same result. No errors in console. I’m switching to another editor for now (as this is only a borrow-laptop and my other Macs have versions of Atom which works without this issue), so no need to spend more time on this. Thanks a lot!