Auto intend with space instead of tab?


#1

How I can set Atom to intend my code automatically with spaces instead of tabs?

I usually use tabs, but now I have a project where I must use spaces. I have turned off the auto-intend and I am doing spaces manually, but I keep forgetting the }…

Any tips?


#2

The easiest way is to:

  1. Launch Atom
  2. Open the Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  3. Go to the Editor Settings section
  4. Scroll down to “Tab Type” and set it to “soft”