Atoms UI still sluggish


#1

I followed the development of atom since the beginning but never actually used it aside from some short tests because it was to slow for me. Now after there were huge improvements in performance and start up time I would really like to switch from sublime to atom because there are some features and plugins that I am really intrigued by.

So I just downloaded the most recent version and installed some basic plugins - mostly syntax highlighting, minimap, colorpicker, no fancy stuff.

The UI still feels very sluggish to me. It’s not that I am not able to do my work but there is this slight latency for everything I do: typing, scrolling, opening new tabs, switching tabs…

I am on a macbook pro 13" (non-retina). If looking into the dev tools timeline I see a lot of “long frames” and a few warnings regarding forced layout calculations in the scrollbar component.

I am wondering if this a problem everybody just got used to / is ignoring or if there is something wrong with my setup?


Scrolling lags/blurs/feels sluggish v1.7.3. on retina MacBook Pro
#2

I would guess something wrong with your setup, given no other information. I used Atom for years on a 2011 non-Retina 13" MBP and didn’t have any sluggishness problems (though performance is also often in the eyes of the beholder).


#3

Same thing here, running the latest version, but on a retina MBP. Scrolling is noticeably more blurry/clunky/slower than in, say, Sublime Text 3.

I’ve tried using --safe and the same still happens. I’ve tried running it with --force-device-scale-factor=1 and it seems to improve, but the text becomes blurred. Some previous posts I found also seemed to point to a particular issue with resolution on the Mac, but I have yet to reach a solution.

This really sucks, because Atom wins over ST3 except for this particular issue…

Update

So far, I’ve narrowed the problem down to the HiDPI of the retina MacBook Pro, after hearing other users reporting the same (this has been going on for a while, apparently). Actually, I’ve switched to the same resolution (1280x800) but with regular DPI (using RetinaDisplayMenu) and it went away. This is impractical, however, because everything just becomes blurry.

Anyone else experiencing the same?