Atomic-emacs on Mac : could not write a '\\'


#1

Hi there !

I’m using (and enjoying) atomic-emacs on my Mac, that lets me use both atom and emacs keybindings but I often run into an issue…

The keybinding on an Apple french keyboard to write a ‘’ is ‘alt-shift-/’. I don’t know why but it just doesn’t work while atomic-emacs is enabled.

I’ve gone though their keymap.cson and found some ‘alt-\\’ that could be a source of conflict. I disabled it : it obviously wasn’t.
Then I’ve tried to remap ‘alt-shift-/’ to a coffee function that writes ‘\’ at my cursor position. I’ve tried ‘alt-shift-:’ too, since ‘:’ is under ‘/’ on my (oh so evil) keyboard.

Until now, i’ve found no solution…

Working in both C and LaTeX, with no backslashes I’m kinda lost…

Hope someone can help ! :slight_smile:


#2

It looks like you may be running into this:


#3

Thanks but sadly no…

I’ve tried the package and it didn’t changed…

I’ve tested a few strokes : it’s not that the right Alt key isn’t recognized, it’s the shortcut itself.


#4

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.


#5

Apparently there’s no callback associated to it.

The strange is that originally ‘alt-maj-/’ isn’t an atom shortcut but a system binding


#6

I’m not familiar with alt-maj. Is maj a different key modifier? Or is it a different name for one of the standard ones: Shift, Control, Alt, Super/OS/Windows, Fn?


#7

Sorry, maj is a french synonym for shift :slight_smile: