AtomHelper High CPU Usage

I second this (so far).

Just started getting this all of a sudden. Packages installed: Arduino. AtomHelper spikes to 100% CPU usage periodically. Using Atom 1.18.0 on an rMBP (mid 2012), macOS 10.12.4. Been using Atom for a while, and didn’t get this until just now. I might have to switch editors if a full comprehensive solution isn’t found.

Atom 1.18 is having quite high CPU usage on fedora25 too. As soon as atom starts it takes about 95% of the CPU and then hovers around 99-100% of the CPU usage and sometimes it shuts down the machine when ever I’m using some other app like chrome.

Make sure that you don’t have a .git directory in your home folder.

1 Like

As for my Mac, I confirm that removing (or moving somewhere else) .git from home directory solved the problem. Yay, Atom works again!

I created .git to backup .bash_profile and didn’t even think it may be the cause for AtomHelper going nuts.

I’ve been using git to back up my dotfiles for a while, and I modeled my setup after these dotfiles. I recommend you take a look, because I find it to be a very good system for transferring my preferences across multiple machines.

Still having high CPU on 2012 MBP on Sierra. Atom v1.19.0

Running safe mode doesn’t help, don’t have git folder in the project map, don’t have spell check plugin.

Thanks. Atom Helper was using ~1.9 Gb of Memory in Activity Monitor.
I discovered that I accidentally ran git init in my User home directory (instead of my MyApp subdirectory), which generated the folder /User/<my_username>/.git, so when I was using an application in /User/<my_username>/MyApp/ it was tracking changes for all my files in the parent User directory (instead of just the MyApp subdirectory), which I discovered when I ran git status.

I resolved the issue as follows:

  1. Change directory back to /User/<my_username>
  2. Permanently delete the .git/ folder (Git repository) and its contents that was tracking changes there
  3. Switch into the subdirectory of MyApp
  4. Create an empty Git repository there instead
  5. Open the MyApp files in Atom
cd ~
rm -rf .git/
cd MyApp
git init
atom .

After following steps above the memory issue was fixed.

1 Like

Constant issues with the helper at 100% CPU.

macOS Sierra Version 10.12.6

Model Name: MacBook Pro
Model Identifier: MacBookPro14,3
Processor Name: Intel Core i7
Processor Speed: 3.1 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Boot ROM Version: MBP143.0160.B02
SMC Version (system): 2.45f0

What version of Atom are you running @andrewjohnstrong (atom -v)?

Also, Is there any difference in safe mode (atom --safe)?

Version 1.21.1 x64

How do I run it in safe mode?

  1. Open the command line.
  2. Type atom --safe.

That definitely seems to have resolved the issue. So it must be an
extension?

Yes. A package is probably contributing heavily to the problem, if not causing it. There’s not a way to identify which packages are using how many CPU cycles, but if you go through your list of packages and make educated guesses as to which ones are doing the most background work, you can test through trial and error.

High CPU usage is very likely to be caused by .git in the home folder /Users//.git as many have pointed out already.

Try and check if the /.git/ folder is large in size to get an indication of how much activity is being logged.
Check if Atom Helper is also using a lot of memory in addition to high CPU usage, also a strong indicator that .git is involved.

Some have already provided a simpel solution to remove .git from the home folder and initiate it in a dedicated project folder

Had the same suddenly beginning on my 15" rMBP.

I followed 2 steps to eliminate the issue. maybe it helps someone.

  1. first i removed the .git folder from “/Users//”
  2. i had a large data folder (60.000+ files) in one of my projects due to an upcoming migration. i moved this folder out of my source/project directory.

afterwards, everything was fine.

This .git folder from “/Users//” thing is not in my case. I don’t have .git folder in my /Users/ folder or my home folder.

AtomHelper is eating more than 100% CPU usage (cores) every time I start Atom.

By the way I am using Atom version 1.30.0 in macOS 10.13.6 under macbook pro 15" with touch panel.

I guess I know what the problem is now.

If I close all projects and start an empty Atom.app, it tries to set my Home folder as its project folder, and that will cause AtomHelper eagerly trying to understand what is in my Home folder.

Do you have autocomplete-paths installed? I’ve found it has an negative impact when working in a folder with a lot of content (like a home folder).

Still happening.
My Mac started burning hot while using Atom starting from version 1.31.

It also happens on safe mode so it is not related to packages.
I also started encountering some weird issues (like this one I’ve opened a thread about: Right-click menu disappear by itself after seconds) but none of this happened until a few weeks ago so I have to guess it’s because of the updates (?)

Please look for this, I love this editor but I cannot work in team with this annoying overheating noise as background anymore

(I’ve a dual-core i5 Retina MacBook Pro 13" running macOS 10.14)