Atom writes one space back from selected


#1

I dont know how to solve this or explain it so i upload two screenshots.
The letter A is just for example.
Thanks for your time,


#2

Have you tried running Atom in safe mode? Type atom --safe on a command line. If the fixes it then the problem is in one of your packages.


#3

Thanks for your answer! But i tried and it doesn’t work :frowning:


#4

Are you on the latest version of Atom? If so then submit a report on atom/atom. Be sure to include atom version and os version and how to make it happen.


#5

Yup, same problem. Writes everything 1 space off since I upgraded to Atom 1.1. Everything worked fine until the upgrade.


#6

Thanks all for the replies!


#7

Is this seti-syntax ? That theme is broken since the launch of 1.1. There’s a css line you can comment to fix it.


#8

yes it was the seti-syntax Thanks a lot!


#9

I’m surprised safe mode doesn’t turn off themes. That’s not very safe.


#10

It did at one point. I put the code in to ensure that it loaded built-in themes instead of blank white canvas :laughing:


#11

Maybe then overwrite theme with default One Dark on safe mode ?


#12

For me it does on Atom 1.3.0-dev-something. It uses the atom-dark theme, which I’m definitely not using myself…


#13

Yep … the code is still there:


#14

I also just tried it and it works as I expected (using Atom v1.3.0-dev-69dfdd0 on Mac OS X 10.11.1), the default themes are loaded in Safe Mode. Here’s what I did:

  1. Installed Seti Syntax using apm install seti-syntax
  2. Configured Seti Syntax as my Syntax theme in Settings View
  3. Completely exited Atom
  4. Launched Atom using atom --safe . from the command line
  5. Opened the Dev Tools and inspected the workspace element

Expected and Actual: Atom Dark UI and Atom Dark Syntax were loaded: