Atom won't work properly!


#1

Whenever I open up Atom, this comes up. It randomly happened one day and I have no clue how to get it back to normal.It looks like this:


#2

Try closing all Atom windows, then delete or rename ~/.atom, then restart atom. This should work like a fresh install.


#3

I tried that. And I also tried uninstalling and reinstalling, but the problem still persists. Any other suggestions?


#4

Are there any errors in the dev console?


#5

How do I check that?


#6

It’s Toggle Developer Tools in the top menu under View/Developer. On some machines it can be done with F10 and on some with Ctrl-Shift-I.


#7

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#8

When I opened Atom the bar at the top is now gone, and none of the shortcuts are working.

I would assume I’m using the most current version of the program since I reinstalled today. I am using Windows 10, but I think the program existed when I still had Windows 7. The problem still occurs when I use atom --safe.