Atom wont start


#1

Hi,

ubuntu 17.10, nvidia gtx730

Atom : 1.23.1
Electron: 1.6.15
Chrome : 56.0.2924.87
Node : 7.4.0

i’ve been running atom for over a month with no issues at all, suddenly last night have stopped working, the process seems to be running but there is no window or can’t tab to this.

i’ve tried running atom --safe, atom --no-gpu --clear-window-state, etc as well as remove ~/.atom folder

reinstalled, upgraded all packages etc, can anyone please advise what other steps to troubleshoot ?


#2

Anyone at all ?? this is a blocker… i’ve had to move back to pyCharm as a result of this.


#3

Did anything at all about your setup change when things stopped working for you? Did you install 1.23.1 and it stopped working?

If you start Atom in the foreground can you share any output you see?

atom --safe -f

Lastly, can you confirm that you installed from the official .deb from https://atom.io?


#4

Hi Rsese,

Didnt install anything else, just was working away on some code, and my box crashed, so i restarted and couldnt launch again.

yeap installed the deb from atom.io, trying to reinstall now and will test out with --safe -f

I see the icon in the gnome but i can’t tab to it, and also when i push ALT+TAB the gnome application preview acutally shows a small window of it but i can’t see it when i click in it!!!

god man… i really want atom working, pyCharm is pretty nasty as in resource hog


#5

no difference… but oddly enough if i take a screenshot atom shows up in the screenshot, is there any other versions that are confirmed stable/working ?


#6

Hi.

Come over to the dark side… install MS Windows on your machine.
:smirk:…{evil laugh}

Seriously though - It is dreadful news to hear about your struggles.
Atom is not the only game in town - but there should be some way to salvage your situation.
I am on Windows and will not be much use to you… some ideas though ->

  • Could you be a bit more specific please, what file were you offered and how did you install the software?
    Are you sure you received the complete download?

  • Try to share some screenshot or even a mobilephone photo of how it looks.

  • Which version did you have that worked?
    Was it still on Ubuntu V17.10?

  • Did you try to revert back to an older Atom version that worked for you?
    You can look for these at https://github.com/atom/atom/releases.

Good luck to ya!
- Dan


#7

HI Dan,

Windows ? … sorry no chance in hell bro :slight_smile:

Remove PyCharm crap…and using sublime now, it’s so-so i still prefer atom :frowning: and after years of vi im hooked on an ide now of only a month of atom.

i installed the deb of the latest version at the time, and then resinstalled with version from pasted above. additionaly tried the beta 1.24.1 as well, also tried last 2 previous versions as well. I had the original deb i installed

1393c91ab9c3e5b277a17a44793f12a5 atom-amd64.deb
4da1d1326dec0e6134af354bfcc1f30e atom-amd64.deb

Here is the only thing i can find in syslog

Dec 21 21:50:52 qwerty dbus[845]: [system] Activating via systemd: service name=‘org.bluez’ unit='dbus-org.bluez.service’
Dec 21 21:50:53 qwerty org.gnome.Shell.desktop[1574]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4000039 (Atom)
Dec 21 21:50:53 qwerty org.gnome.Shell.desktop[1574]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4000001 (Atom)


#8

Problem solved. gahhh it’s embarassing… but here is root cause.

second monitor hdmi to tv screen which i only use if watching a movie,. for some reason atom was only app that was opened there, everything else opens on desktop monitor :frowning:

looool