Atom won't start


#1

Hi, my OS is Windows 8.1 Single Language. I’m using Atom for about 2 months. And since 2 weeks ago when i opened it through the taskbar it only show a very fast command prompt, and atom does not opened.

I’ve tried to reinstall (without uninstalling) and it keep does the same as before.
What’s wrong with it? Does my installation files are corrupted or something?

Below is my screenshot of the command prompt. Sorry if it’s show transparent, because it opened very fast.


Atom won't launch (Windows 7)
#2

Try this:

  1. Delete or move the $HOME\.atom\storage directory
  2. Launch Atom again from a command prompt using atom --safe

#3

Hi, thanks for your reply. The problem has been solved by myself by uninstalling it first and then install Atom again.

But, just in case if the same problem happen again, can you please told me :

  1. The directory should I delete / move is the storage directory, right?
  2. And how to launch Atom from command prompt?

Once again, thank you very much for your replies. I really appreciate your answer :smile:


#4

Hi @dhimaspratama - It’s good to hear that you were able to resolve your problem.

Here are the answers to your other questions:

  • Yes, you’ll need to move or delete Atom’s storage directory.
  • On Windows (and Linux), when Atom installs, it installs two command-line tools; atom and apm. You can launch Atom using the atom command. To get started, type atom -h in command prompt.

#5

Wow, thankyou for your answer @GigabyteGiant . It really helps me. Now i can launch atom from my command prompt. And sorry for late reply.

Thank you very much. Keep going :)grinning:


#6

@GigabyteGiant Can’t access atom from cmd. Says atom is not recognized as an internal or external command.
Have tried reinstalling but still does not work.


#7

Is AppData/Local/atom/bin in your PATH?