Atom won't open


#1

So I installed a few packages and Atom won’t open now, how to I debug it or how do I remove it completely from Linux?


#2

You can use atom --safe from the command line to open an Atom instance that has no packages loaded.

If it’s your user settings (init script, etc.) that are causing the issue, try renaming your files in your ~/.atom directory.


#3

Safe Mode also disables one’s init.coffee, so no need to muck with the ~/.atom directory.


#4

How do you figure out which plugin is the culprit for crashing the editor? Is there a running log file anywhere?


#5

I would disable them all and then enable them one at a time.


#6

Man an easier way would be welcomed.


#7

Yep, I suggested this quite a while ago for helping with this kind of thing:

Perhaps one day I’ll get the free time to actually work on it :laughing:


#8

Yeah I just gave up and uninstalled all packages. Starting from scratch :angry:


#9

My package package-cop is designed for this problem, although its UI leaves a lot to be desired.


#10

I restarted atom with --safe option, closed all tabs and updated all pages. I then closed atom and restarted it normally (without --safe option). This worked for me.
I don’t have a lot of packages, so it was probably closing the open tabs that solved the issue, but I’m not sure.


#11

…and how do you start Atom when atom --safe doesn’t work?


#12

What is happening?


#13

Well, when I would click the icon in my dock (on my Mac) the app would bounce for a second then stop. So it would not launch. I tried all sort of things to try and fix it. I finally fixed the issue by downloading the latest release from GitHub, unzipping and replacing the existing app in the Applications directory.


#14

Im on OSX
I am having this issue today, after i updated to 1.14 and updated about 6 packages. I will let everyone know what my solution is.

1st Try - Usuccessful
went to atom.io and downloaded a new app and replaced it with my current.

2nd Try - successful
deleted my app from my computer and installed a new app from atom.io. Then restarted my computer and it works now.


#15

What worked is this

I went to:
C:\Users\myUSERNAME\AppData\Local\atom
and I saw several app versions: app-1.19.3, app-1.19.2, etc

I opened the last one and inside there was another instance of atom.exe - I ran that and it worked.